Announcement

Collapse
No announcement yet.

UOSteam Intel ICD OpenGL Driver Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • UOSteam Intel ICD OpenGL Driver Error

    UOSteam Intel ICD OpenGL Driver Error
    solution by parsnip, May 21, 2017.

    This is a little guide for things to try if you get the dreaded "cannot find the name of Intel ICD OpenGL driver" error when loading UOSteam.

    A simple solution that works for many is to roll back your graphics driver but this isn't a very sustainable solution in the long run.

    A slightly more complex solution is to move driver files and tweak some registry settings. The following steps worked for me and one other person so far - Hopefully it proves useful for others!

    Get your graphics card GUID

    *Open Device Manager from Control Panel (or devmgmt.msc from command prompt)
    *Navigate down to your graphics card under Display Adapters
    *Double-click on the graphics card entry to load its Properties
    *Click on the Details tab
    *Click the Property drop down and select Class GUID
    *Take note of this value (Mine was {4d36e968-e325-11ce-bfc1-08002be10318})

    Find the registry entry for OpenGL

    *Open your registry (Type regedit in your command prompt or press WindowsKey-R to open the Run prompt and type regedit.exe in there)
    *Navigate to the following entry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{YOURGUIDHERE}\0000
    *Scroll down to OpenGLDriverName and OpenGLDriverNameWoW
    *Take note of the path of the .dll files in those two registry entries For example, my paths were: C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\ig9icd64.dll and C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\ig9icd32.dll
    *Leave the regedit open, we'll come back to that in a moment but first ....

    Go to the Driver folder

    *Open Windows Explorer and navigate to the location of those files we found in the registry. For example, in my case, this was C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\
    *Copy the two files (ig9icd64.dll and ig9icd32.dll), navigate to C:\Windows\ and paste a copy of the files there (Ctrl-V)
    *You should now have a copy of the files under the original location and under C:\Windows\

    Edit the registry

    *Open regedit again and double click on OpenGLDriverName
    *Change the entry to remove the path, leaving just the file name. For example, C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\ig9icd64.dll becomes ig9icd64.dll
    *Repeat the process for OpenGLDriverNameWoW (It should look something like the image below)

    Close the registry editor

    Restart your computer

    Now try loading UOSteam - You should now be free of errors!
    Last edited by Archon; 06-18-2017, 08:59 AM.
    Owner - UO Central

  • #2
    Second Solution if that did not work:

    1) this problem on my Chinese mini PC solved with uninstall Microsoft drivers and install manufacturer drivers on Intel HD videocard, microsoft auto-updates drivers, But I pointed it to use the other default drivers

    2) Also this problem was on mine new Laptop Dell 6567 = i have integrated video ~ Intel HD 620 + Nvidia 1050 4GB
    i tryed many different drivers - original Intel, manufacturer Dell...
    and i don't understand what helped rollback\install\reinstall drivers
    or after all - deleting Game from default folder and copy Game folder from mine PC to Notebook and start UoSteam Game from D:\ ... directory
    Owner - UO Central

    Comment


    • #3
      UOSteam Intel ICD OpenGL Driver Error
      Tutorial Video Solution
      https://youtu.be/-ti2avZ-Ck8
      Owner - UO Central

      Comment


      • #4
        Sounds like it may just need a driver update? Here is the link to manually update the drivers
        https://downloadcenter.intel.com/dow...ows-15-46-?v=t

        Or you can try to see if you can trigger an automatic update by following these directions
        1. Press the start button and go to Control Panel
        2. Click on "Device manager"
        3. Now right click on the video card shown and select "Update Driver Software".
        4. Then select Search automatically
        Last edited by UO Evolution; 08-28-2018, 10:35 AM.
        UO Evolution "The Game Has Evolved"

        http://www.uoevolution.com
        http://www.uoevolution.com/forum
        http://www.uoevolution.com/wiki

        Comment


        • #5
          I also found this post while researching this issue:

          How-to: bypass "The driver being installed is not validated for this computer"
          https://steamcommunity.com/app/23325...9190911446231/
          UO Evolution "The Game Has Evolved"

          http://www.uoevolution.com
          http://www.uoevolution.com/forum
          http://www.uoevolution.com/wiki

          Comment


          • #6
            I working on this issue today and found that using the troubleshooting option fixed the issues

            Attached Files
            UO Evolution "The Game Has Evolved"

            http://www.uoevolution.com
            http://www.uoevolution.com/forum
            http://www.uoevolution.com/wiki

            Comment

            Working...
            X