No announcement yet.

All accounts deleted suddenly without reason

  • Filter
  • Time
  • Show
Clear All
new posts

  • All accounts deleted suddenly without reason

    Hello, I am fairly new to RunUO. I had finally got a fresh renaissance era server up and running. I used nerun's distro to populate the world, had done some nice decorating etc. had a few friends joining up with me to have some fun... then today when I went to log on, it says "no accounts detected, would you like to make an owner account?" I didn't change any code, I have not touched it since I last played.

    I've found out the following now:

    1) all accounts associated with the server have been deleted
    2) the server has been completely wiped. no vendors, no spawns, all the work I did completely gone, without reason.

    Has this ever happened to anyone? This is incredibly frustrating... The code is still all the same. Literally, nothing changed. Yet the server is completely gone. What!??! The server name and all that is still the same...I'm not just logging into the wrong server or something.

    I was playing, I logged out for a few hours, came back and my shard is wiped.

    If anyone has any wisdom to share, I would be very appreciative as there is almost 0 information on this problem.

  • #2
    Upon making a new account I have also discovered that I do not have GM/admin powers. I can't load Nerun's anymore... this is just... really mind boggling.


    • #3
      I thought I should probably add: Using RunUO 2.5 , Client, Razor as client assistant, Windows 10.

      Exactly how it happened:

      I ran runuo.exe, the code compiled and the listener kicked on. I opened razor and entered my credentials into the uo client. I then got stuck at the 'verifying account' screen. I thought hmm that's weird. I closed razor, closed runuo.exe. I restarted runuo.exe and I got the message:

      "there are no accounts detected, would you like to make the owner account?"

      I hit no, thinking it must be an error and my acct will still be there. I type in my old admin credentials into the client and it makes a new account, and since I had typed 'n' this new account did not have admin powers. When I run runuo.exe now, it does not prompt me to create an owner account, so at this point I think I probably have to do a full clean reinstall of runuo. It's odd though, I looked through the uo client folders and found the accounts that no longer show up in the account list. Yet I can't find the new account I made...which does show up in the account list. I wonder where it's being saved, perhaps I am somehow pointing to the wrong client?

      I will try to track down where this new account was saved and hopefully that will provide me with some insight.

      I was poking around in the accounting folder and I was noticing an ip limiter. I had made my owner account, a second non-gm account, and then earlier today a roommate made an account. That would have been effectively 3 accounts on the same ip. The line of code seems to limit it to 1, does that somehow... break the server?


      • #4
        The plot thickens:

        There is no data folder on my computer for the new account I created without admin powers. I have done a full system search and the file folder simply does not exist. The only trace of it's existence I can find is on the accounts.xml file in the 'saves' folder. So somehow this file must have been wiped and overwritten. Does anyone know the script that overwrites this file? I think getting the server back to where it was will be easy enough, but I don't want this to happen again, and I have no idea why it happened. I'm going off of 15 year old forum posts, most of which are hosted on runuo.COM which doesn't exist anymore...

        I still don't know:

        a) why the server wiped
        b) what script writes to accounts.xml
        c) why my old accounts are not being recognized anymore
        d) how to prevent this from happening again

        my only theory is that by having more accounts than my ip limiter allowed, I somehow wiped accounts.xml and the file was overwritten with the new account. I have gone into the ip limiter and changed the max accounts per ip to 5. I guess I will start over and pray that my accounts don't magically get deleted. Strangely though, my friends accounts were wiped as well.

        I am mostly posting all this for someone like me, who will stumble across this website 10 years after it's heyday, struggling to find any relevant info. I will see this through to the end, for you, future visitor.