Announcement

Collapse
No announcement yet.

UOSteam will not run on gaming laptop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • UOSteam will not run on gaming laptop

    Hi guys I was hoping somebody could help me. I have a gaming laptop with a nvidia GPU in it. According to the laptop manufacturer's tech support they have disabled the onboard Intel GPU due to complaints about the previous version using the Intel GPU whenever it wanted. Anyway, I cannot get UOSteam to run as it basically does not have a Intel GPU, I just get a "can't find the Intel graphics" error everytime I try to run UOSteam. Does anyone have any idea how to get around this? Much appreciated.

  • #2
    Here is a guide for things to try if you get the error "cannot find the name of Intel ICD OpenGL driver" when loading UOSteam.

    If you are having the error "Can't find the name of the Intel ICD OpenGL driver" when they start UOSteam, I think I found the reason and the fix. There was a recent update to some Intel graphics drivers which is not compatible with UOSteam. Open "device manager" expand "Displays", right click your video card, and click Properties. Then find the Driver tab and select "roll back driver" - this reverts to a previous version which, in my case, had no problem with UOSteam.

    This second fix was posted by Archon is a fairly complex solution and you must move driver files and change some registry settings.

    http://www.runuo.net/forum/forum/sof...l-driver-error

    Get your graphics card GUID
    1. Open Device Manager from Control Panel (or devmgmt.msc from command prompt)
    2. Navigate down to your graphics card under Display Adapters
    3. Double-click on the graphics card entry to load its Properties
    4. Click on the Details tab
    5. Click the Property drop down and select Class GUID
    6. Take note of this value

    Find the registry entry for OpenGL
    1. Open your registry (Type regedit in your command prompt or press WindowsKey-R to open the Run prompt and type regedit.exe in there)
    2. Navigate to the following entry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{YOURGUIDHERE}\0000
    3. Scroll down to OpenGLDriverName and OpenGLDriverNameWoW
    4. Take note of the path of the .dll files in those two registry entries For example, my paths were: C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\ig9icd64.dll and C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\ig9icd32.dll
    5. Leave the regedit open, we'll come back to that in a moment but first ....
    Go to the Driver folder
    Open Windows Explorer and navigate to the location of those files we found in the registry. For example, in my case, this was C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\
    Copy the two files (ig9icd64.dll and ig9icd32.dll), navigate to C:\Windows\ and paste a copy of the files there (Ctrl-V)
    You should now have a copy of the files under the original location and under C:\Windows\

    Edit the registry
    1. Open regedit again and double click on OpenGLDriverName
    2. Change the entry to remove the path, leaving just the file name. For example, C:\Windows\System32\DriverStore\FileRepository\igd lh64.inf_amd64_4ac0038ddc82c1c6\ig9icd64.dll becomes ig9icd64.dll
    3. Repeat the process for OpenGLDriverNameWoW (It should look something like the image below)
    4. Close the registry editor
    5. Restart your computer

    Now try loading UOSteam - You should now be free of errors!

    You might also look at www.uosteam.com
    RunUO - Ultima Online Emulator - www.runuo.net

    Comment


    • #3
      I am also getting this error, that fix doesn't seem to work for it though I even did the 0001 folder and everything.

      Comment


      • #4
        You might just try UO Razor for a temp fix, that always works
        www.uorazor.com
        RunUO - Ultima Online Emulator - www.runuo.net

        Comment


        • #5
          No auto loot agent on razor , thanks though been still fiddlng with it for 4 days straight and still nothing seems to work, even tried orion but thats a whole basket of what the hell.

          Comment


          • #6
            Try simply updating the drivers? https://downloadcenter.intel.com/dow...ows-15-46-?v=t
            RunUO - Ultima Online Emulator - www.runuo.net

            Comment


            • #7
              I've tried that multiple times, even got on support with intel to see if they had any suggestions. Nothing's working as of now. Pretty much think uosteams dead if you guys are planning on upgrading your hardware. Be nice if the developer could release the source or do a minor update it's a shame because it's the very best UO assistance programs that I know of

              Comment

              Working...
              X